AHD(4) | Kernel Interfaces Manual | AHD(4) |
To compile in debugging code:
For SCSI busses:
scsibus* at ahd?
Driver features include support for narrow and wide busses, fast, ultra, ultra2, ultra160, and ultra320 synchronous transfers, packetized transfers, tagged queueing, and 512 SCBs.
The AHD_DEBUG_OPTS option is used to control which diagnostic messages are printed to the console when AHD_DEBUG is enabled. Logically OR the following bits together:
Value | Function |
0x0001 | Show miscellaneous information |
0x0002 | Show sense data |
0x0004 | Show Serial EEPROM contents |
0x0008 | Show bus termination settings |
0x0010 | Show host memory usage |
0x0020 | Show SCSI protocol messages |
0x0040 | Show mode pointer of the chip register window |
0x0080 | Show selection timeouts |
0x0100 | Show FIFO usage messages |
0x0200 | Show Queue Full status |
0x0400 | Show SCB queue status |
0x0800 | Show inbound packet information |
0x1000 | Show S/G list information |
0x2000 | Enable extra diagnostic code in the firmware |
The AHD_REG_PRETTY_PRINT option compiles in support for human-readable bit definitions for each register that is printed by the debugging code. However, it also bloats the compiled size of the driver by approximately 215KB.
May 16, 2009 | NetBSD 6.1 |