PCIBIOS(4) | Kernel Interfaces Manual (i386) | PCIBIOS(4) |
Ideally, the boot firmware of a machine (a.k.a. BIOS) should set up all PCI devices; assigning them I/O and memory addresses and interrupts. Alas, this does not always happen, so there is some PC specific code that can do the initialization when NetBSD boots.
Options:
The value is a logical or of power-of-2s of allowable interrupts:
IRQ Value | IRQ Value | IRQ Value | IRQ Value |
0 0x0001 | 4 0x0010 | 8 0x0100 | 12 0x1000 |
1 0x0002 | 5 0x0020 | 9 0x0200 | 13 0x2000 |
2 0x0004 | 6 0x0040 | 10 0x0400 | 14 0x4000 |
3 0x0008 | 7 0x0080 | 11 0x0800 | 15 0x8000 |
The kernel global variable pcibios_irqs_hint holds this value, so a user can override this value without kernel recompilation. For example:
And type the following command on “db>” prompt:boot -d
Then type the following to continue to boot:write pcibios_irqs_hint 0x0a00
c
And type the following commands at the “(gdb)” prompt:gdb --write /netbsd
set pcibios_irqs_hint=0xa00
quit
If PCIBIOS_INTR_FIXUP_FORCE is specified in addition to the PCI_INTR_FIXUP, the PCI Interrupt Routing table takes precedence. In this case, a kernel with PCIBIOSVERBOSE shows “WARNING: overriding irq XX” in the PCI routing table.
If a PCI interrupt router is not known, normally interrupt configuration will not be touched.
But if PCIBIOS_INTR_GUESS is specified in addition to the PCI_INTR_FIXUP, and if a PCI interrupt routing table entry indicates that only one IRQ is available for the entry, the IRQ is assumed to be already connected to the device, and corresponding PCI Interrupt Configuration Register will be configured accordingly.
October 9, 2005 | NetBSD 6.1 |