VP(4) | Kernel Interfaces Manual (VAX) | VP(4) |
The Versatec printer/plotter is normally used with the line printer system. This description is designed for those who wish to drive the Versatec directly.
To use the Versatec yourself, you must realize that you cannot open the device, /dev/vp0 if there is a daemon active. You can see if there is a daemon active by doing a lpq(1), and seeing if there are any files being sent. Printing should be turned off using lpc(8).
To set the Versatec into plot mode you should include <sys/vcmd.h> and use the ioctl(2) call
ioctl(fileno(vp), VSETSTATE, plotmd);
where plotmd is defined to be
int plotmd[] = { VPLOT, 0, 0 };
and vp is the result of a call to fopen(3) on stdio. When you finish using the Versatec in plot mode you should eject paper by sending it a EOT after putting it back into print mode, i.e. by
int prtmd[] = { VPRINT, 0, 0 }; ... fflush(vp); ioctl(fileno(vp), VSETSTATE, prtmd); write(fileno(vp), "\04", 1);
June 5, 1993 | NetBSD 6.1 |