GPIOCTL(8) | System Manager's Manual | GPIOCTL(8) |
gpioctl | [-q] device attach device offset mask [flag] |
gpioctl | [-q] device pin [0 | 1 | 2] |
gpioctl | [-q] device pin [on | off | toggle] |
gpioctl | [-q] device pin set [flags] [name] |
gpioctl | [-q] device pin unset |
Each GPIO device has an associated device file in the /dev directory. device can be specified with or without the /dev prefix. For example, /dev/gpio0 or gpio0.
GPIO pins can be either “read” or “written” with the values of logical 0 or 1. If only a pin number is specified on the command line, the pin state will be read from the GPIO controller and displayed. To write to a pin, a value must be specified after the pin number. Values can be either 0 or 1. A value of 2 “toggles” the pin, i.e. changes its state to the opposite. Instead of the numerical values, the word on, off, or toggle can be used.
To
Only pins that have been configured at securelevel 0, typically during system startup, are accessible once the securelevel has been raised. Pins can be given symbolic names for easier use. Besides using individual pins, device drivers that use GPIO pins can be attached to a gpio(4) device using the gpioctl command. Such drivers can be detached at runtime using the drvctl(8) command.
The following configuration flags are supported by the GPIO framework:
Note that not all the flags may be supported by the particular GPIO controller.
When executed with only the gpio(4) device name as argument, gpioctl reads information about the GPIO device and displays it. At securelevel 0 the number of physically available pins is displayed, at higher securelevels the number of configured (set) pins is displayed.
The options are as follows:
# gpioctl gpio0 20 set out pp
Write logical 1 to pin 20:
# gpioctl gpio0 20 1
Attach a onewire(4) bus on a gpioow(4) device on pin 4:
# gpioctl gpio0 attach gpioow 4 0x01
Detach the gpioow0 device:
# drvctl -d gpioow0
Configure pin 5 as output and name it error_led:
# gpioctl gpio0 5 set out error_led
Toggle the error_led:
# gpioctl gpio0 error_led 2
November 13, 2011 | NetBSD 6.1 |