IP6(4) | Kernel Interfaces Manual | IP6(4) |
The header has the following definition:
struct ip6_hdr { union { struct ip6_hdrctl { uint32_t ip6_un1_flow; /* 20 bits of flow ID */ uint16_t ip6_un1_plen; /* payload length */ uint8_t ip6_un1_nxt; /* next header */ uint8_t ip6_un1_hlim; /* hop limit */ } ip6_un1; uint8_t ip6_un2_vfc; /* version and class */ } ip6_ctlun; struct in6_addr ip6_src; /* source address */ struct in6_addr ip6_dst; /* destination address */ } __packed; #define ip6_vfc ip6_ctlun.ip6_un2_vfc #define ip6_flow ip6_ctlun.ip6_un1.ip6_un1_flow #define ip6_plen ip6_ctlun.ip6_un1.ip6_un1_plen #define ip6_nxt ip6_ctlun.ip6_un1.ip6_un1_nxt #define ip6_hlim ip6_ctlun.ip6_un1.ip6_un1_hlim #define ip6_hops ip6_ctlun.ip6_un1.ip6_un1_hlim
All fields are in network-byte order. Any options specified (see Options below) must also be specified in network-byte order.
ip6_flow specifies the flow ID. ip6_plen specifies the payload length. ip6_nxt specifies the type of the next header. ip6_hlim specifies the hop limit.
The top 4 bits of ip6_vfc specify the class and the bottom 4 bits specify the version.
ip6_src and ip6_dst specify the source and destination addresses.
The IPv6 header may be followed by any number of extension headers that start with the following generic definition:
struct ip6_ext { uint8_t ip6e_nxt; uint8_t ip6e_len; } __packed;
The following socket options are supported:
Datagrams with a hop limit of 1 are not forwarded beyond the local network. Multicast datagrams with a hop limit of zero will not be transmitted on any network but may be delivered locally if the sending host belongs to the destination group and if multicast loopback (see below) has not been disabled on the sending socket. Multicast datagrams with a hop limit greater than 1 may be forwarded to the other networks if a multicast router (such as mrouted(8)) is attached to the local network.
This option improves performance for applications that may have no more than one instance on a single host (such as a router daemon) by eliminating the overhead of receiving their own transmissions. It should generally not be used by applications for which there may be more than one instance on a single host (such as a conferencing program) or for which the sender does not belong to the destination group (such as a time-querying program).
A multicast datagram sent with an initial hop limit greater than 1 may be delivered to the sending host on a different interface from that on which it was sent if the host belongs to the destination group on that other interface. The multicast loopback control option has no effect on such delivery.
struct ipv6_mreq { struct in6_addr ipv6mr_multiaddr; unsigned int ipv6mr_interface; };
ipv6mr_interface may be set to zeroes to choose the default multicast interface or to the index of a particular multicast-capable interface if the host is multihomed. Membership is associated with a single interface; programs running on multihomed hosts may need to join the same group on more than one interface.
If the multicast address is unspecified (i.e., all zeroes), messages from all multicast addresses will be accepted by this group. Note that setting to this value requires superuser privileges.
const char *policy = "in ipsec ah/transport//require"; char *buf = ipsec_set_policy(policy, strlen(policy)); setsockopt(s, IPPROTO_IPV6, IPV6_IPSEC_POLICY, buf, ipsec_get_policylen(buf));
struct in6_pktinfo { struct in6_addr ipi6_addr; /* src/dst IPv6 address */ unsigned int ipi6_ifindex; /* send/recv if index */ };
struct ip6_hbh { uint8_t ip6h_nxt; /* next header */ uint8_t ip6h_len; /* length in units of 8 octets */ /* followed by options */ } __packed;
The inet6_option_space() routine and family of routines may be used to manipulate this data.
This option requires superuser privileges.
struct ip6_dest { uint8_t ip6d_nxt; /* next header */ uint8_t ip6d_len; /* length in units of 8 octets */ /* followed by options */ } __packed;
The inet6_option_space() routine and family of routines may be used to manipulate this data.
This option requires superuser privileges.
struct ip6_rthdr { uint8_t ip6r_nxt; /* next header */ uint8_t ip6r_len; /* length in units of 8 octets */ uint8_t ip6r_type; /* routing type */ uint8_t ip6r_segleft; /* segments left */ /* followed by routing-type-specific data */ } __packed;
The inet6_option_space() routine and family of routines may be used to manipulate this data.
This option requires superuser privileges.
Instead of using sendmsg(2) to specify option values, the ancillary data used in these calls that correspond to the desired header options may be directly specified as the control message in the series of control messages provided as the argument to setsockopt(2).
The IPV6_PKTINFO, IPV6_HOPLIMIT, IPV6_HOPOPTS, IPV6_DSTOPTS, and IPV6_RTHDR options will return ancillary data along with payload contents in subsequent recvmsg(2) calls with cmsg_level set to IPPROTO_IPV6 and cmsg_type set to respective option name value (e.g., IPV6_HOPTLIMIT). These options may also be used directly as ancillary cmsg_type values in sendmsg(2) to set options on the packet being transmitted by the call. The cmsg_level value must be IPPROTO_IPV6. For these options, the ancillary data object value format is the same as the value returned as explained for each when received with recvmsg(2).
Note that using sendmsg(2) to specify options on particular packets works only on UDP and raw sockets. To manipulate header options for packets on TCP sockets, only the socket options may be used.
In some cases, there are multiple APIs defined for manipulating an IPv6 header field. A good example is the outgoing interface for multicast datagrams, which can be set by the IPV6_MULTICAST_IF socket option, through the IPV6_PKTINFO option, and through the sin6_scope_id field of the socket address passed to the sendto(2) system call.
Resolving these conflicts is implementation dependent. This implementation determines the value in the following way: options specified by using ancillary data (i.e., sendmsg(2)) are considered first, options specified by using IPV6_PKTOPTIONS to set “sticky” options are considered second, options specified by using the individual, basic, and direct socket options (e.g., IPV6_UNICAST_HOPS) are considered third, and options specified in the socket address supplied to sendto(2) are the last choice.
By using connect(2) or bind(2), raw socket input is constrained to only packets with their source address matching the socket destination address if connect(2) was used and to packets with their destination address matching the socket source address if bind(2) was used.
If the proto argument to socket(2) is zero, the default protocol (IPPROTO_RAW) is used for outgoing packets. For incoming packets, protocols recognized by kernel are not passed to the application socket (e.g., tcp(4) and udp(4)) except for some ICMPv6 messages. The ICMPv6 messages not passed to raw sockets include echo, timestamp, and address mask requests. If proto is non-zero, only packets with this protocol will be passed to the socket.
IPv6 fragments are also not passed to application sockets until they have been reassembled. If reception of all packets is desired, link-level access (such as bpf(4)) must be used instead.
Outgoing packets automatically have an IPv6 header prepended to them (based on the destination address and the protocol number the socket was created with). Incoming packets are received by an application without the IPv6 header or any extension headers.
Outgoing packets will be fragmented automatically by the kernel if they are too large. Incoming packets will be reassembled before being sent to the raw socket, so packet fragments or fragment headers will never be seen on a raw socket.
struct iovec iov[2]; u_char buf[BUFSIZ]; struct cmsghdr *cm; struct msghdr m; int found, optval; u_char data[2048]; /* Create socket. */ (void)memset(&m, 0, sizeof(m)); (void)memset(&iov, 0, sizeof(iov)); iov[0].iov_base = data; /* buffer for packet payload */ iov[0].iov_len = sizeof(data); /* expected packet length */ m.msg_name = &from; /* sockaddr_in6 of peer */ m.msg_namelen = sizeof(from); m.msg_iov = iov; m.msg_iovlen = 1; m.msg_control = buf; /* buffer for control messages */ m.msg_controllen = sizeof(buf); /* * Enable the hop limit value from received packets to be * returned along with the payload. */ optval = 1; if (setsockopt(s, IPPROTO_IPV6, IPV6_HOPLIMIT, &optval, sizeof(optval)) == -1) err(1, "setsockopt"); found = 0; while (!found) { if (recvmsg(s, &m, 0) == -1) err(1, "recvmsg"); for (cm = CMSG_FIRSTHDR(&m); cm != NULL; cm = CMSG_NXTHDR(&m, cm)) { if (cm->cmsg_level == IPPROTO_IPV6 && cm->cmsg_type == IPV6_HOPLIMIT && cm->cmsg_len == CMSG_LEN(sizeof(int))) { found = 1; (void)printf("hop limit: %d\n", *(int *)CMSG_DATA(cm)); break; } } }
The following errors specific to IPv6 may occur when setting or getting header options:
W. Stevens and M. Thomas, Advanced Sockets API for IPv6, RFC 2292, February 1998.
S. Deering and R. Hinden, Internet Protocol, Version 6 (IPv6) Specification, RFC 2460, December 1998.
R. Gilligan, S. Thomson, J. Bound, and W. Stevens, Basic Socket Interface Extensions for IPv6, RFC 2553, March 1999.
W. Stevens, B. Fenner, and A. Rudoff, UNIX Network Programming, third edition.
May 19, 2011 | NetBSD 6.1 |